Back to overview
Downtime
Deployment Error
Apr 5, 2026 at 2:25am UTC
Affected services
Distribution interface
Resolved
Apr 5, 2026 at 2:30am UTC
Fixed
Affected services
Updated
Apr 5, 2026 at 2:26am UTC
fix implemented, monitoring results
Affected services
Created
Apr 5, 2026 at 2:25am UTC
Error occurred when adding labor entry to excel.js
Affected services